Delay in Push Notification Delivery
Incident Report for Pulsara
Postmortem

Today, at roughly 14:35 MST our internal monitoring systems alerted us of push notification failures.

At 14:38 MST our engineering team discovered that the root cause of this incident was a failure with one of our third party vendors. During this time, no push notifications on either Android or iOS were sent. Pulsara video calls and all other data components continued to work during this time. Our development team continued to monitor this event and prepared backup alternatives to deploy to our production environment if needed.

At 14:55 MST our third party vendor resumed working status and push notifications began to work again. At this time, all new push notifications were sent as expected.

As of 14:55 MST, Pulsara was completely back up and running at 100%.

Posted Mar 14, 2020 - 00:19 UTC

Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 20:58 UTC
Monitoring
Push notifications have now been restored. We are currently monitoring this event and will have more details to follow.
Posted Mar 13, 2020 - 20:57 UTC
Identified
We have identified an issue with one of our third party vendors. We are actively working on a fix for this. Currently, no push notification are being sent.
Posted Mar 13, 2020 - 20:50 UTC
Investigating
We are actively investigating delays in push notification delivery.
Posted Mar 13, 2020 - 20:35 UTC
This incident affected: Third Party Mobile Push Notifications - US.