Degraded performance around Zoll ECG uploads

Incident Report for Pulsara

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 01:24 UTC

Investigating

We are currently investigating an increase in errors related to ECG attachments from ZOLL monitors.
Posted Jul 20, 2026 - 21:59 UTC
This incident affected: Public API - US.